Google Chrome

How To Fix ‘Could Not Load Shockwave Flash’ Error In Google Chrome

 

So, you want to watch a video in Youtube. You open your Google Chrome browser, heads over to Youtube, searches for the video and starts playing it… well not yet. Because you are greeted with the errors ‘Couldn’t load plug-in’, and ‘Could not load Shockwave Flash’ as seen below. Frustrating, it is. So, now what? You can try re-installing the browser, but that won’t fix the error. You will continue to get the same message.

1

Let’s see how we can fix this very easily. Yes, its very easy!

Before we start, there are two directions you can take – both will take you to the same location. I will describe both here, so you can decide which fits you better, or helps you to follow better.

 

The Long-and-Detailed Route

1. Click on the Customize button on the right-side on the menu bar to open up the list of options. Click on Settings.

2

2. A new tab will open up. Scroll down and click on Show Advanced Settings.

3

3. More options… Find the heading ‘Privacy’ and click on Content Settings.

4

4. The Content Settings dialog box shows up. Scroll down and find Plug-insClick on the hyperlink ‘Disable individual plug-ins.

5

5. Another tab comes up with the list of installed plug-ins.

Wait here for a second as I’m going to show you how to reach the same tab directly without all the above long steps.

 

The Short-and-Direct Route

1. Simply open a new tab and type the following in the address bar. chrome://plugins/

8

Ok, so now we are here at the plug-ins tab, lets see who is the one causing the plug-in error which prevented us from watching videos in Chrome. The error did mention ‘Shockwave Flash’. So find the plug-in Adobe Flash Player – Shockwave Flash. You would find two versions of the same plug-in installed/enabled. But you need just one! Yes, only one is fine.

Click on Details

Click on Details to see more options for the plug-in. Now you see both the versions with a Disable option attached to each one.

Disable the one version that points to C:\Users\.. and keep the version pointing to the C:\Windows\.. enabled (As shown below).

7

 

Now, open a new tab/window, open Youtube and play a video. Voila! Enjoy!

Hope this helped you to save yourself the time to install another browser. Share your thoughts below.

 

About these ads

245 comments on “How To Fix ‘Could Not Load Shockwave Flash’ Error In Google Chrome

  1. Did you click on the little +/- sign in upper right (or left) hand corner to see details? I thought only one version until I clicked on this – then I could see both versions.

    Like

  2. I love you! I struggled with this, and then somehow it stopped. But then days ago it did it and this was the only solution that actually worked! THANK YOU!

    Like

  3. :( :( pls help me so solve this problem .
    someone who help me plss ?
    :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :(
    hmm . pls help me

    Like

    • TH\his is the solution if you only have one plugin.
      First, browse as a guest and disable the only plugin. That solves the YouTube problem. Then, end the guest session and return to your normal user. Download adobe flash player even if you already have it, then follow the directions here.

      Like

  4. well it really solved my problem Thanks a lot….
    This staement “”You would find two versions of the same plug-in installed/enabled. But you need just one! Yes, only one is fine”””
    is very important. I found two versions of flash player enabled and on version of shockwave enabled. So i just disabled the the two version of flash player and voila everything working again :) thanks again :)

    Like

    • Hi Keegan, did you click in the + sign on the right up corner against the flash plug-in to open up the details. You should be able to see two adobe shockwave plug-ins each with a disable option.

      Like

      • Hi i done every thing you said Up until Plugins there is only one shockwave flash and its in the program files folder Please help i got hacked by a remote admin tool and they stuffed my pc up i fixed every thing apart from this and windows installer gets disabled every 10 mins thanks in anvance

        Like

    • You may see one is Adobe Flash Player and the other one is Adobe Shockwave Player . Go Ahead disable the Adobe Flash Player and leave the other one. I did it to mine and it worked.

      Like

  5. didn’t work for me. i pressed the + icon and only still see one version of Flash (the one that points to C:\users\…) I tried disabling that and now Chrome wants me to download Flash from the Adobe site. And when I try, i get a message that Chrome has Flash built in already and to just enable it in the Settings.!!!

    Like

  6. Thank you SO much!!! The error had been driving me crazy & I’d tried many things, but this is the only one that worked!

    Like

  7. Worked for me, thx. But I have another problem. All of a sudden, one day, no sound would play on any YouTube videos. If I download the video and play it, no problem, but none of my browsers will play any sound on YouTube. I just today finally got Chrome to play sound but both Firefox and iExporer are silent on YouTube videos!

    Like

  8. Hi, I don’t have two versions installed, and it the path isn’t taking me to C:\user, it’s taking me to C:\Program Files (x86). I don’t know if that is the same thing or not but i’m still having issues with my shockwave flash. I’m using windows 8.

    Like

  9. it worked thanks…………….guys if you dont have 2 versions its because on the plug in page you did not click on the details tab !!! click on it and you have 2

    Like

  10. I have only one version of adobe wat can i do now. If i click disable another option with C:/Users is not displaying. Can any of you find the problem of my solution.

    Like

  11. Sorted. Thanks.
    As others have said, you need to cilck on the “Details” drop-down box in the top right-hand corner, after you get to the Plug-ins tab.
    Then disable 1 of the 2 plug-ins as instructed above. Good luck.

    Like

  12. I have disable 1 of the 2 plug-ins as instructed, well I didn’t see the error message again but still I can’t play the video :(

    Like

  13. Hi guys. Can someone help help? I do have two files, but the locations are different from what you mentioned above. Which one should I disable? Thank you.

    Name: Shockwave Flash
    Description: Shockwave Flash 11.7 r700
    Version: 11.7.700.225
    Location: /Applications/Google Chrome.app/Contents/Versions/27.0.1453.116/Google Chrome Framework.framework/Internet Plug-Ins/PepperFlash/PepperFlashPlayer.plugin
    Type: PPAPI (out-of-process)
    Disable
    MIME types:
    MIME type Description File extensions
    application/x-shockwave-flash Shockwave Flash
    .swf
    application/futuresplash FutureSplash Player
    .spl
    Name: Shockwave Flash
    Description: Shockwave Flash 11.1 r102
    Version: 11.1.102.64
    Location: /Library/Internet Plug-Ins/Flash Player.plugin
    Type: NPAPI
    Disable
    MIME types:
    MIME type Description File extensions
    application/x-shockwave-flash Shockwave Flash
    .swf
    application/futuresplash FutureSplash Player
    .spl

    Like

      • urse
        NOVEMBER 9, 2013 @ 9:09 PM
        Hi….Thank u kindly for the fix er up er :)….I have 2 adobe flash player files, and other stuff like Native Client, and Chromes remote desktop viewer, as well as Adobe reader, and Photo gallery stuff….Could that be a reason y I’m always crashing, and not responding, and all that good stuff? and….if possible….can u tell me if I need all that other stuff, or can I delete them as well. Thank u in advance :) I didn’t know how to email u, so I clicked reply, I’m sorry.

        0 0 Rate This

        Like

  14. This didn’t work for me because I only had 1 plugin in the list.

    I just disabled the plugin and it now works (You did tell us to). This is because I have Flash already installed, while Chrome was trying to use it’s built-in Flash Plugin.

    I hope this helps some people.

    Like

  15. THANK YOU THANK YOU THANK YOU !!!!! I installed the new version and it wouldn’t let me watch anything and then i found this website and it saved my day :) :) :)

    Like

  16. Hi guys,
    I disabled the pepperflash one as mentioned in the tutorial above.
    The message went away and Youtube videos are working again but I cannot go beyond 360p.
    Could someone please help me?

    Thank you in advance!

    Like

  17. This worked for me but there weren’t 2 listed. There was ‘Adobe Shockwave’ and ‘Adobe Flash Player’. I disabled Flash Player. Next time I opened a site I got a message that I needed to update Shockwave. Did that and now it works. Love the super simple and funny way you explained what to do. Thanks!!!

    Like

  18. didn’t work. It said I needed to update Adobe Shockwave Player, and whenever I did it told me “Could not Load Shockwave for Director”. D’you know whaaaaat that means??????????

    Like

  19. Thanks :-)
    it worked.. initially i found only one but I used Find(search) for “Shock” I found other instances and just disabled them to get it working good…

    Like

  20. i have Adobe Shock wave for Director Netscape and Adobe Flash Player – Version: 11.9.900.117
    Shock wave Flash 11.9 r900 my shock wave does not say c/user or c/ windows it says c/ programs but my director shock wave says c/ windows do i need the director shock wave and is it the problem?

    Like

  21. Hi….Thank u kindly for the fix er up er :)….I have 2 adobe flash player files, and other stuff like Native Client, and Chromes remote desktop viewer, as well as Adobe reader, and Photo gallery stuff….Could that be a reason y I’m always crashing, and not responding, and all that good stuff? and….if possible….can u tell me if I need all that other stuff, or can I delete them as well. Thank u in advance :)

    Like

  22. Yes, okay… Interesting to give this a try….(Especially since I am not on Windows right now, but on linux Lucid 10.04 11.2 r202. Since no flash has worked yet and I am just configuring this today not much to lose…is there? Okay ready?
    So far Words”” hasn’t loaded yet so i tried youtube and it reads that:You need to upgrade your Adobe Flash Player, the one I just disabled. (It wasn’t working anyhow) I think I need a certain flash player to work with older AMD’s One I know before had security issues, yet I had to use it anyway. Okay I just checked my Movie Player I think it is Totem and it still cannot identify the flv stream that I am attempting. Batting O.00!! Now What!!

    Like

  23. Thank you. Fixed my problem! However, I had to randomly choose which version to disable because mine weren’t labeled the same as yours. Luckily, I realized you could enable it again and choose the other one if you selected the wrong one.

    Like

  24. If I go to the file where the PepperFlash is there is no delete button or anything how do I delete it please please please please please help I have not been able to do crap for like a week.

    Like

  25. I have 3 versions… the “bad” one is already disabled. I have two versions in c:\\Windows etc. :( Should I disable one of those? No App or Library under my username, I’m doing a search for that dll file…

    Like

  26. When I clicked on the link the little picture of the shockwave plug-in thing just showed up :( Sorry, but this didn’t help me what-so-ever :”( Pls help me with this!!

    Like

  27. This doesn’t seem to work on Mac. I really wish I could post a screen shot, but mine does NOT have a “details” button. I cannot expand or see both files. There is no way to click on them. This is all I see:

    Adobe Flash Player (2 files) – Version: 11.9.900.170
    Shockwave Flash 11.9 r900
    Name: Shockwave Flash
    Description: Shockwave Flash 11.9 r900
    Version: 11.9.900.170
    Location: /Applications/Google Chrome.app/Contents/Versions/31.0.1650.63/Google Chrome Framework.framework/Internet Plug-Ins/PepperFlash/PepperFlashPlayer.plugin
    Type: PPAPI (out-of-process)
    Disable
    MIME types:
    MIME type Description File extensions
    application/x-shockwave-flash Shockwave Flash
    .swf
    application/futuresplash FutureSplash Player
    .spl
    Name: Shockwave Flash
    Description: Shockwave Flash 11.9 r900
    Version: 11.9.900.170
    Location: /Library/Internet Plug-Ins/Flash Player.plugin
    Type: NPAPI
    Disable
    MIME types:
    MIME type Description File extensions
    application/x-shockwave-flash Shockwave Flash
    .swf
    application/futuresplash FutureSplash Player
    .spl
    Disable Always allowed

    Like

  28. Actually… Best way to watch the videos is – copy the link to mozilla firefox!
    Why? Because disabling the Shockwave plugin version you might not be able watch local videos in your comp with eg VLC player because it gets you error “Missing driver …” – reenable Shockwave plugin back and copy online video URL into Firefox and you’re back on the road again

    Like

    • Hello, first of all, thank you for visiting! I would like to clarify two things.
      1. We are not removing or disabling the Shockwave plug in completely here. The plug in will remain installed in the computer and we are only disabling the duplicate corrupted version of the plug in that causes the conflict in the browser. Those who have only one version listed in the plugins page, might need to try reinstalling the plug in. I haven’t noticed any issue in playing local media in any media players because of this process.
      2. Regarding switching to Firefox, the same Shockwave error appears there as well under similar conditions. So I wouldn’t recommend ditching chrome when we can fix this issue in under a minute and continue browsing.

      Like

  29. Uninstall Chrome, And Adobe Flash and Shockwave if you only show one plug in. After all are installed you should see 2 now. Disable the one for C/Users.

    Like

  30. Hi!you’re fix worked and I successfully disabled the plugin but now the ads on the youtube videos are showing up so I tried to delete the file completely but I can’t seem to find the file in C:/users, do you know where I can go from there to try and find the file? THANKS!

    Like

  31. So I only had one file also, so I disabled it downloaded an updated version of the flash player and then enabled that. Hope it helped someone

    Like

  32. So I’m running Windows 7 Chrome and I tried all these steps that the Adobe forums and Microsoft forums told me to do, and nothing is working. My laptop was running fine yesterday, then today I turn it on and I get the “Could not load Shockwave Flash” error. I’ve done everything known in existence and nothing works. I only have the c:users edition for my flash player, I dont know how to get c:windows. Please help :’( Thanks!

    Like

  33. It worked, but after I disabled it, it required me to have the new version of Flash to watch any Youtube videos. What should I do?

    Like

  34. HELP- i used your fix- and TY! worked, just like you said. HOWEVER, ever since that fix- i can’t highlight text in my emails anymore!! this is killing me since i live in email!!

    Like

  35. It worked. In the chrome://plugins page under adobe flash player i could see two extensions. One is NPAPI and other PPAPI… the latter is not working. PPAPI is by Google and NPAPI by Netscape. I just tested by disabling PPAPI and enabling NPAPI and it worked … the vice versa is not working… . If i had misunderstood any of these please update me.

    Like

  36. The solution as described above worked for me. I just had to find and click the “details” link on the right hand side of the page where Shockwave Flash plugin is listed to get the 2 versions of Shockwave to show before disabling the “Users” version. Thanks for taking the time to put this solution up on the web!

    Like

  37. AMAZING! People that can only find one version of shockwave are just dumb and aren’t even reading the instructions properly.

    Like

  38. I was on track until the C:/Users/ and the C:/Windows/ part. My locations on both of them had a whole bunch of stuff but not those.

    Like

  39. Great!!! I installed Adobe flash player…and got 2 shockwav players in the pluggins…Enabled the one starting with C:\Windows….And it started working…Thank u….!!!!!

    Like

  40. Thanks! and for those that only have one that means you’ve never installed Adobe’s Shockwave Flash Player. To fix this go on Adobe official website and download Shockwave Flash Player after you’ve done that disable plugin with location c:\users (this is chrome’s built-in flash player) and enable (if not already) Shockwave Flash Player with location c:\windows. Voila That’s it. Hope this Helps.

    Like

  41. Thanks man! That was soo easy like you said but please re-position your comment box just below your post to avoid me scrolling all the way down to leave a reply.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s